Honda CBR XX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Bird had been sitting for years before I got it. Had to replace the pump/filter due to bad gas left in the bike.
Pump now runs but bike runs (kind of) on No1 cylinder only. Spark is good so injectors are suspect I'm thinking.
To remove the injectors the manual has you removing the throttle body before removing the rail. Is that the correct way? Or can I just remove the rail and then the injectors, leaving the throttle body in place?
Seems like it would work, just wondering what other people did.

Thanks for suggestions
Chris
 

·
Super Moderator
Joined
·
8,146 Posts
It should be just fine and the way I'd do it anyway just unbolt the fuel rail and pull them.
 

·
Super Moderator
Joined
·
8,146 Posts
Send them out to an injector cleaning service. We have a few over here that use an ultrasonic cleaner. Then the flow check them. Some have even included stop action photos of the spray pattern.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Left the throttle bodies in place and just pulled the rail. Very easy job. Sent injectors out to NW Fuel in BC, Canada. Dropped off at 4PM, ready at 11AM the next day. Top service, great guys. Re-installed and the bike runs like new. 3 injectors were blocked, delivering zero fuel, one was at 50%. Ultrasonically cleaned, serviced and re-tested. All are now within 2% on flow, with 'as-new' pattern. New baskets and seals included. Bike started first try. On the road, bike runs just like one with < 10,000 km. Cheers.
 
1 - 6 of 6 Posts
Top