Honda CBR XX Forum banner

1 - 9 of 9 Posts

·
Roasties
Joined
·
4 Posts
Discussion Starter #1
Hi All!!

I am new to this forum and needless to say -its awesum!!

I have a problem with my 1999 (FI) Blackbird.
I blew the CDI 2 Months ago and got a used one from a 2006 Bird.

Problem I have now is that my Speedo and Taco is dead - I believe the 2006 one had digital Dash?
Mine has Analog dash.

The Temp gauge, Fuel gauge, lights and everything seems to be working fine, just the Speedo & Taco are dead

Can someone please help!!
 

·
Registered
Joined
·
14,013 Posts

·
Roasties
Joined
·
4 Posts
Discussion Starter #3

·
Registered
Joined
·
283 Posts
Maybe he was referring to the fact you posted the exact same question in 3 different threads, it is frowned upon on most forums.
Usually you get the best results when you introduce yourself in the proper forum and ask your question once.
Succes with your problem!
 

·
Premium Member
Joined
·
6,010 Posts
Several things here..

I am supprised that the 2006 ECU works in the 1999 for the following reasons.

1, 2001 and above has HISS and the 1999 doesnt have the sensor for the key so Im very supprised it even starts since the ECU will not be recieving any key tag information.
2, The AU 2001 and above have a lamda sensor in the exhaust which the 1999 doesnt, this should immediately trigger en ECU warning code in the FI light (if the FI light was working)
3, There was another thread around here somewhere that the poster claimed that he needed to change 3 pinounts on the ECU (i think it was 3) just for it to work.


Now back to the dash. I am using a 2005 dash on the 1999 so from a wiring perspective there is only the subloom that is different between the 1999 ecu and the dash.


A second issue was that the 1999 ecu delivers +5v to the FI light so that the responce time is quick enough to get the FI lamp to flash correctly, The 2006 wouldnt do this becuase it expects an LED in the dash that lights up much quicker than an incandescant bulb. So you simply may not be getting the correct voltage to the bulb for it to light up.

Speedo and Tacho. These are fed from a couple of sensors on the engine and i cant remember if they are direct to dash via the ecu.

Hope this info at least starts you looking in the right direction ... i will see if i can find aformentioned post about the ECU upgrade and the wiring pinouts.

Oh you didnt mention where you got the ECU from... ECU's are different dependant on country or origin.
 

·
Resident Eh?hole.
Joined
·
17,177 Posts
Speedo and Tacho. These are fed from a couple of sensors on the engine and i cant remember if they are direct to dash via the ecu.
Speedo takes signal direct from the sensor, I don't know if pulse rates varied at all through the years, but I have a feeling they didn't. I do know that the tach is fed solely by a square wave output from the ECM.
 

·
Premium Member
Joined
·
6,010 Posts
Speedo takes signal direct from the sensor, I don't know if pulse rates varied at all through the years, but I have a feeling they didn't. .
Considering my 2005 dash still displays the same incorrect speed readings as any non speedo healed bird does, I dont think that the pulse rates varied either.
 

·
Premium Member
Joined
·
6,010 Posts
It may be worth checking the curcuit film on back of the dash as this is a common point of failure on the analogue dashes.. there maybe a broken track and the problem could be completely unrelated to the ECU change.
 
1 - 9 of 9 Posts
Top